CVE-2026-110264
10 CRITICALPublished 2026-10-22 · Updated 2026-10-22
AI risk analysis
- Summary
- An integer overflow vulnerability in GitLab's regex compilation allows unauthenticated users to execute arbitrary code on the server under certain conditions, leading to full system compromise.
- Exploitability
- Exploitation requires sending a specially crafted regular expression to trigger the integer overflow; it is theoretically feasible but no public exploit exists yet.
- Blast radius
- Successful exploitation grants remote code execution with the privileges of the GitLab application, potentially compromising the entire server and any connected services or data.
- Detection
- No reliable host or network indicator is derivable from the published description.
- Prioritized remediation
- Upgrade to GitLab 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, or 19.5.1 or later.
Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.
NVD description
An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-190
All references
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- CRITICALCVE-2023-54400PoC
- CRITICALCVE-2026-101499
- HIGHCVE-2026-104995
- CRITICALCVE-2026-107459
- CRITICALCVE-2026-107780PoC
- HIGHCVE-2026-111391PoC
- CRITICALCVE-2026-14269
- HIGHCVE-2026-15027
Related by shared AI tags and CWE weakness class. Browse the full archive.