← Back to search

CVE-2026-112407

8.8 HIGHpublic exploit available

Published 2026-10-20 · Updated 2026-10-22

AI risk analysis

Summary
The IAM policy in AWS CICD-toolchain-for-serverless-applications versions 1.0.7–1.0.10 incorrectly assigns excessive privileges to the pipeline role, allowing authenticated users with push access to deploy templates that grant themselves broader permissions than intended, enabling full compromise of other resources in the same AWS account.
Exploitability
Exploitation requires authenticated push access to the application source repository and ability to modify or deploy malicious application templates; low barrier for insiders or compromised developer accounts.
Blast radius
Successful exploitation allows attackers to read, modify, or delete any AWS resource accessible to the compromised pipeline role—including S3 buckets, Lambda functions, DynamoDB tables, and other infrastructure—within the same AWS account.
Detection
Monitor CloudTrail for IAM policy updates (e.g., PutRolePolicy, AttachRolePolicy) triggered by the pipeline’s assumed role during CodePipeline execution, especially if those changes grant permissions outside the expected application stack scope; also watch for unusual resource creation/modification events in CloudTrail or Config that correlate with pipeline runs.
Prioritized remediation
Upgrade existing toolchain stacks to version 1.0.11 or later, as explicitly recommended by the vendor.
privilege-escalationiam-misconfigci-cdawspipeline-compromise

Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.

NVD description

Incorrect privilege assignment in the IAM policy of AWS CICD-toolchain-for-serverless-applications 1.0.7 through 1.0.10 allows remote authenticated users with push access to the application source repository to escalate privileges and access or modify resources outside the application stack in the same AWS account via application templates deployed by the toolchain pipeline. To remediate this issue, users should upgrade existing toolchain stacks to version 1.0.11 or later.

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Weaknesses

CWE-266

Public exploit & PoC references

All references

Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.

Related CVEs

Related by shared AI tags and CWE weakness class. Browse the full archive.