CVE-2026-114612
9.9 CRITICALpublic exploit availablePublished 2026-10-22 · Updated 2026-10-23
AI risk analysis
- Summary
- The LiteLLM proxy server reused a single cryptographic context for secrets and session tokens, enabling authenticated internal users to forge administrator credentials by crafting malicious metadata that, when replayed as a bearer token, granted full administrative access via the MCP stdio endpoint.
- Exploitability
- An authenticated internal user with low privileges can exploit this flaw without user interaction or complex conditions, requiring only knowledge of the vulnerable API flows.
- Blast radius
- Successful exploitation grants full administrative control over the proxy, enabling arbitrary command execution through the MCP stdio endpoint, potentially compromising all downstream LLM API calls and sensitive data processed by the system.
- Detection
- Look for API-key authentication requests returning encrypted metadata containing unexpected or malformed credential structures, and monitor for bearer tokens that decode to administrative privileges without corresponding high-privilege login events; no reliable host or network indicator is derivable from the published description.
- Prioritized remediation
- Upgrade to LiteLLM version 1.100.4, 1.101.3, 1.102.2, 1.103.1, or 1.104.0-rc.2 (or later) immediately.
Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.
NVD description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-269, CWE-345, CWE-441
Public exploit & PoC references
- https://github.com/BerriAI/litellm/commit/1d5fdc87fed66b49e1df8cf7d708ad93249eb7d0
- https://github.com/BerriAI/litellm/commit/9161d7f9d6073603ba61ee4aa5e2c0ef5b37a81b
- https://github.com/BerriAI/litellm/commit/9fa1a641119dd0d4fe43e93622eae5f482ceb63f
- https://github.com/BerriAI/litellm/commit/a80eacacee118fbed54e3d98f239d17a63fac818
- https://github.com/BerriAI/litellm/commit/f7cd90f09e9716652b38daec9f0640cdf49d582b
- https://github.com/BerriAI/litellm/releases/tag/v1.100.4
- https://github.com/BerriAI/litellm/releases/tag/v1.101.3
- https://github.com/BerriAI/litellm/releases/tag/v1.102.2
- https://github.com/BerriAI/litellm/releases/tag/v1.103.1
- https://github.com/BerriAI/litellm/releases/tag/v1.104.0-rc.2
- https://github.com/BerriAI/litellm/security/advisories/GHSA-7hp6-4w63-5g45
All references
- https://github.com/BerriAI/litellm/commit/1d5fdc87fed66b49e1df8cf7d708ad93249eb7d0
- https://github.com/BerriAI/litellm/commit/9161d7f9d6073603ba61ee4aa5e2c0ef5b37a81b
- https://github.com/BerriAI/litellm/commit/9fa1a641119dd0d4fe43e93622eae5f482ceb63f
- https://github.com/BerriAI/litellm/commit/a80eacacee118fbed54e3d98f239d17a63fac818
- https://github.com/BerriAI/litellm/commit/f7cd90f09e9716652b38daec9f0640cdf49d582b
- https://github.com/BerriAI/litellm/releases/tag/v1.100.4
- https://github.com/BerriAI/litellm/releases/tag/v1.101.3
- https://github.com/BerriAI/litellm/releases/tag/v1.102.2
- https://github.com/BerriAI/litellm/releases/tag/v1.103.1
- https://github.com/BerriAI/litellm/releases/tag/v1.104.0-rc.2
- https://github.com/BerriAI/litellm/security/advisories/GHSA-7hp6-4w63-5g45
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- HIGHCVE-2026-103758PoC
- HIGHCVE-2026-100586PoC
- CRITICALCVE-2026-103692
- HIGHCVE-2026-12269
- HIGHCVE-2026-49450PoC
- HIGHCVE-2026-92958PoC
- CRITICALCVE-2026-94205PoC
- HIGHCVE-2022-51019PoC
Related by shared AI tags and CWE weakness class. Browse the full archive.