CVE-2026-116852
9.1 CRITICALPublished 2026-10-30 · Updated 2026-10-30
AI risk analysis
- Summary
- A remote code execution (RCE) vulnerability exists in Widget Options plugin versions <= 4.2.5 due to improper input validation (CWE-94), allowing authenticated authors to inject and execute arbitrary PHP code.
- Exploitability
- Exploitation requires high-privilege access (author role or higher) with no user interaction, making it difficult for unauthenticated attackers but serious for compromised or insider threats.
- Blast radius
- Successful exploitation could lead to full system compromise including data theft, backdoor installation, and lateral movement within the WordPress environment.
- Detection
- Look for suspicious PHP code execution in web server logs (e.g., POST requests to /wp-admin/admin-ajax.php with base64-encoded payloads or eval() calls) and unexpected file creation/modification under wp-content/uploads/ by author-level users.
- Prioritized remediation
- Upgrade to Widget Options version 4.2.6 or later, which contains the official patch for this vulnerability.
rcewordpresspluginphp-injectionauth-bypass
Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.
NVD description
Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-94
All references
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- HIGHCVE-2026-92174
- HIGHCVE-2026-39776
- CRITICALCVE-2026-94169
- CRITICALCVE-2026-94267
- HIGHCVE-2026-104725PoC
- CRITICALCVE-2026-104748
- HIGHCVE-2026-104759
- HIGHCVE-2026-104797
Related by shared AI tags and CWE weakness class. Browse the full archive.