CVE-2026-121652
5.4 MEDIUMpublic exploit availablePublished 2026-11-03 · Updated 2026-11-03
AI analysis for this CVE has not been generated yet. Raw NVD data is shown below.
NVD description
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Public exploit & PoC references
All references
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- MEDIUMCVE-2012-20003PoC
- MEDIUMCVE-2012-20004PoC
- MEDIUMCVE-2012-20005PoC
- MEDIUMCVE-2013-20009PoC
- MEDIUMCVE-2014-125131PoC
- MEDIUMCVE-2014-125132PoC
- MEDIUMCVE-2015-20130PoC
- MEDIUMCVE-2016-20098PoC
Related by shared AI tags and CWE weakness class. Browse the full archive.