← Back to search

CVE-2026-15230

8.1 HIGH

Published 2026-08-05 · Updated 2026-08-05

AI risk analysis

Summary
The flaw in YayPricing WordPress plugin allows any authenticated user to overwrite pricing configurations and disclose private coupon codes due to missing capability checks.
Exploitability
Exploitation is relatively easy as it requires only an authenticated user, such as a subscriber, to perform actions on REST API routes.
Blast radius
If exploited, the impact could be significant, as it allows unauthorized modification of pricing and disclosure of sensitive coupon codes, affecting the store's operations and customer trust.
Detection
No reliable host or network indicator is derivable from the published description.
Prioritized remediation
Upgrade to YayPricing version 3.5.7 or later.
auth-bypasswebconfig-overwritecoupon-disclosure

Analysis generated locally by qwen2.5:7b-instruct (no data left the box). AI-assisted — verify against primary sources before acting.

NVD description

The YayPricing WordPress plugin before 3.5.7 does not perform capability checks on several of its REST API routes, relying only on a shared nonce, allowing any authenticated user such as a subscriber to overwrite the store's pricing configuration and to disclose private coupon codes.

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Weaknesses

CWE-284

References

Data: NVD (public domain). Analysis: local $0 model. Defensive use only.