CVE-2026-39732
9.3 CRITICALPublished 2026-10-30 · Updated 2026-10-30
AI risk analysis
- Summary
- The Transliterator plugin for WordPress versions up to and including 2.5.13 contains an unauthenticated SQL injection vulnerability due to improper input sanitization in a database query.
- Exploitability
- Exploitation is straightforward for remote attackers since no authentication or user interaction is required.
- Blast radius
- Successful exploitation could allow attackers to extract sensitive data from the WordPress database, potentially affecting confidentiality and availability of the underlying system.
- Detection
- Defenders should monitor web server access logs for requests containing suspicious SQL syntax (e.g., UNION SELECT, OR 1=1) in query parameters targeting the Translimiter plugin endpoints.
- Prioritized remediation
- Upgrade to Transliterator version 2.5.14 or later, which contains a fix for this SQL injection vulnerability.
sql-injectionunauthenticatedwordpress-plugincwe-89
Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.
NVD description
Unauthenticated SQL Injection in Transliterator <= 2.5.13 versions.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L
Weaknesses
CWE-89
All references
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- HIGHCVE-2026-89288
- HIGHCVE-2015-20122
- CRITICALCVE-2023-54400PoC
- HIGHCVE-2026-100644PoC
- HIGHCVE-2026-101997
- HIGHCVE-2026-103695
- CRITICALCVE-2026-108107PoC
- HIGHCVE-2026-109573PoC
Related by shared AI tags and CWE weakness class. Browse the full archive.