← Back to search

CVE-2026-54857

9.8 CRITICAL

Published 2026-10-29 · Updated 2026-10-29

AI risk analysis

Summary
The Quirky application before 1.24 suffers from an unauthenticated PHP object injection vulnerability (CWE-502), allowing remote attackers to deserialize arbitrary objects via unsanitized user input, potentially leading to remote code execution or data exposure.
Exploitability
Exploitation is straightforward for remote attackers due to the lack of authentication and direct deserialization of user-controlled input.
Blast radius
Successful exploitation could lead to full system compromise including remote code execution, unauthorized data access, and service disruption across all affected deployments.
Detection
No reliable host or network indicator is derivable from the published description.
Prioritized remediation
Upgrade to Quirky version 1.24 or later, which contains a fix for this vulnerability.
php-object-injectionunauthenticateddeserializationrceweb

Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.

NVD description

Unauthenticated PHP Object Injection in Quirky <= 1.23 versions.

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Weaknesses

CWE-502

All references

Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.

Related CVEs

Related by shared AI tags and CWE weakness class. Browse the full archive.