CVE-2026-93680
9.8 CRITICALPublished 2026-10-29 · Updated 2026-10-30
AI risk analysis
- Summary
- IBM Langflow OSS versions 1.0.0 through 1.12.8 contain an authentication bypass vulnerability (CWE-287), allowing unauthenticated remote attackers to circumvent security restrictions and gain unauthorized access to protected resources.
- Exploitability
- Exploitation is highly likely due to the CVSS vector indicating network accessibility, low attack complexity, and no user interaction or privileges required.
- Blast radius
- Successful exploitation could lead to full system compromise including confidentiality, integrity, and availability impacts across all services exposed by the Langflow application.
- Detection
- No reliable host or network indicator is derivable from the published description.
- Prioritized remediation
- Upgrade to IBM Langflow OSS version 1.12.9 or later, which contains the official fix for CVE-2026-93680.
auth-bypasscwe-287remote-exploitcritical-severitylangflow
Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.
NVD description
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to bypass security restrictions due to improper authentication.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
All references
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- CRITICALCVE-2026-76938
- CRITICALCVE-2026-106013
- CRITICALCVE-2026-110956
- CRITICALCVE-2026-117532PoC
- HIGHCVE-2026-18810PoC
- HIGHCVE-2026-45451
- CRITICALCVE-2026-76474
- CRITICALCVE-2026-86400
Related by shared AI tags and CWE weakness class. Browse the full archive.