CVE-2026-54858
9.8 CRITICALPublished 2026-10-29 · Updated 2026-10-29
AI risk analysis
- Summary
- The Printy plugin for WordPress versions <= 1.13.0 contains an unauthenticated PHP object injection vulnerability (CWE-502), allowing attackers to deserialize arbitrary objects without authentication, potentially leading to remote code execution or data manipulation.
- Exploitability
- Exploitation is straightforward for remote attackers due to the lack of authentication requirements and low attack complexity.
- Blast radius
- Successful exploitation could lead to full system compromise including confidentiality, integrity, and availability impacts across any WordPress site using the vulnerable Printy plugin.
- Detection
- No reliable host or network indicator is derivable from the published description.
- Prioritized remediation
- Upgrade to Printy version 1.13.1 or later, which contains the official fix for this vulnerability.
php-object-injectionunauthenticatedwordpress-plugincwe502critical
Analysis generated locally by garnet-coder (no data left the box). AI-assisted — verify against primary sources before acting.
NVD description
Unauthenticated PHP Object Injection in Printy <= 1.13.0 versions.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
All references
Source data: NVD (nvd.nist.gov), public domain. Exploit-DB.ai adds local AI analysis for defensive use only.
Related CVEs
- CRITICALCVE-2026-54860
- CRITICALCVE-2026-62002
- CRITICALCVE-2026-62005
- CRITICALCVE-2026-54859
- CRITICALCVE-2026-61997
- CRITICALCVE-2026-61998
- CRITICALCVE-2026-62003
- CRITICALCVE-2026-62006
Related by shared AI tags and CWE weakness class. Browse the full archive.